Minutes after the official release of iOS 4.2.1, the folks at the iPhone Dev Team were able to roll out a compatible jailbreak tool for those enjoying the benefits of a hacked device. A compatible version of Cydia is unavailable for the latest iOS right now, but the jailbreak is, in all senses, a go for iPhone, iPod touch, and iPad using the Team’s redsn0w 0.9.6 beta 4.

Important!
Before users proceed with following the steps below, Pctipsbox would like to note that jailbreaking is not particularly encouraged.

Also, see this post for compatible devices and the particularities involving each device model with respect to this jailbreak. For example, this is a “tethered” jailbreak which, for some, may involve hassle they’d rather avoid. Go here to learn more about the drawbacks involved by a “tethered jailbreak.”

With all that out of the way….

Jailbreaking iOS 4.2.1 with Redsn0w 0.9.6b4 on Mac OS X (the steps should apply the same on a Windows PC) More »

An unlock for iOS 4.2.1 is almost ready to go, signals iPhone Dev Team member Musclenerd, via Twitter. Apparently, Apple tried to block their ultrasn0w unlock tool via “aggressive compiler optimization,” but the Team was able to crack it and is gearing up to release a new version that will do the trick for iOS 4.2.1 users, albeit only for those wielding an old-generation handset.

“Finally got ultrasn0w working fully on 4.2.1,” Musclenerd writes on Novemver 27. “Apple inadvertently(!) broke ultrasn0w via aggressive compiler optimization,” the hacker explains.

In a separate note that hit the micro blogging service just minutes ago, Musclenerd adds: “When we update ultrasn0w today, 100’s of thousands (maybe millions?) will see red badge. Trying to make it safe for all.” More »

The latest update from the famous hackers, titled “Thanksgiving with Apple”, reveals that “The best news of all is for owners of iPhone3G, older iPhone3GS, and non-MC iPod touch 2G.”

The Team explains that, “Due to a combination of our original pwnage2 exploit, the arm7_go exploit, 24kpwn, and limera1n, your device is “just as jailbreakable as ever.” You reap the full benefit of an untethered 4.2.1 jailbreak.”

However, the same thing cannot be said about owners of a new-generation device, or “more decent devices”, as the Team likes to call them.

There’s good news and bad news here as well.

For starters, the Team claims that “due to geohot’s limera1n exploit, all recent devices can be jailbroken (this will be true until Apple released new hardware that fixes geohot’s limerain exploit in the bootrom).” More »

With iOS 4.2 knocking on our doors, the infamous iPhone Dev Team is making sure jailbreakers and unlockers are well informed about the risks involved by updating to Apple’s stock iOS 4.2 IPSW.

In a recent blog update, the group of hackers responsible for PwnageTool confirms that all devices on all iOS firmware versions can be jailbroken, but that jailbreakers should refrain themselves from updating to iOS 4.2 until Cydia and PwnageTool are updated.

“By all accounts, we’re within a few days of Apple’s official public release of Firmware 4.2,” the Team writes. “Here’s what you need to know.”

“Thanks to geohot’s limera1n exploit, and our original pwnage2 exploit, and @pod2g’s ipod2g-MC exploit, absolutely all devices at all iOS firmware versions are capable of being jailbroken,” the iPhone Dev Team elaborates. More »